Delay in email delivery

Minor incident Outbound channels E-mail
2021-12-09 07:00 CEST · 1 day, 10 hours, 11 minutes

Updates

Resolved

We have resolved the underlying issue and are now approaching usual operational levels.

December 10, 2021 · 17:11 CEST
Issue

We are currently observing delays in email delivery of up to 5h. The team is taking measures and we are already seeing delay times being reduced.

December 10, 2021 · 12:57 CEST

← Back