API degraded

Minor incident API parcelLab App Trackings & Communications
2026-09-07 19:27 UTC · 12 minutes

Updates

Post-mortem

A background database optimization exposed an issue in connection handling, causing slower responses and intermittent API errors.

We restored normal service through a database failover and cleared the accumulated requests. The database optimization has since completed successfully.

To prevent recurrence, we have updated these background operations to release connections promptly, preventing the buildup that caused this incident. We have also added automated tests for this scenario.

September 8, 2026 · 04:13 UTC
Resolved

All metrics have recovered. We continue to monitor.

September 7, 2026 · 19:57 UTC
Monitoring

Issue resolved and database cluster fully operational again. We are monitoring and checking the root cause.

September 7, 2026 · 19:55 UTC
De-escalate

API recovered as the database cluster triggered failover to new nodes.

September 7, 2026 · 19:42 UTC
Issue

A database index build operation is currently degrading API performance leading to slower responses and refused/times out connections. Our team is investigating.

September 7, 2026 · 19:32 UTC

← Back