Login not working
Major incident
parcelLab App
Trackings & Communications
Reporting
Configurations
2025-04-28 22:36 CEST
· 25 minutes
Updates
Issue
April 28, 2025 · 23:01 CEST
Login service is back up, but it requires user session to expire before prompting a new login — you can accelerate that by resetting your cookies for the last 24 hours, e.g. for Chrome like described in this guide: Delete Chrome Cookies (PDF)
Issue
April 28, 2025 · 22:36 CEST
Login to portal is not working since 40+ mins. Team is investigating and resolving the issue.
← Back
parcelLab Status