Service interruoption for app.parcellab.com

Minor incident Portal Trackings & Communications Reporting Configurations
2024-09-19 14:44 CEST · 3 minutes

Updates

Resolved

Systems are available again.

September 19, 2024 · 14:47 CEST
Issue

We are currently experiencing a service interruption on the customer service portal on app.parcellab.com in our North America region.

No customer facing systems are impacted: communications, order status, and returns portal are not affected.

The team is investigating.

September 19, 2024 · 14:44 CEST

← Back